Release Notes: KWIC

5.7.4

Release Date: October 16, 2017

What's New

  • Install and run KWIC as a service on Windows (Linux and Mac alread supported services) (kwic5#31)

  • Add ability to restart KWIC service from kwic.setup (kwic5#84)

  • Various usability improvements in the kwic.setup tool

  • Bug fixes

Known Issues

  • kwic.setup gives errors when configuring with IPv6 addresses (kwic5#105)

  • Due to a known issue with Kaspersky antivirus software, WebSocket connections may fail if Kaspersky is enabled (tickets#602)

    Workaround: Use TLS or disable the antivirus software.

Deprecations

  • None

System Requirements

  • Java Developer Kit (JDK) or Java Runtime Environment (JRE) Java 8 (version 1.8.0_77) or higher

  • While Kaazing supports a variety of platorms, the following operating systems are recommended for production use:

    • RHEL / CentOS 5 or higher
    • Debian 7 or higher
    • Ubuntu LTS 12.04, LTS 14.04, LTS 16.04
    • Windows Server 2008 R2, 2012

    In addition, other platforms like Windows Desktop and Mac OSX are suitable for development

5.7.2

Release Date: September 1, 2017

What's New

  • Enhanced logging to provide more connection details in a friendly format for improved diagnostics (userstories#21)

  • Renamed log file from error.log to kwic.log (kwic5#17)

  • Various usability improvements in the kwic.setup tool

  • Bug fixes

Known Issues

  • Due to a known issue with Kaspersky antivirus software, WebSocket connections may fail if Kaspersky is enabled (tickets#602)

    Workaround: Use TLS or disable the antivirus software.

Deprecations

  • None

System Requirements

  • Java Developer Kit (JDK) or Java Runtime Environment (JRE) Java 8 (version 1.8.0_77) or higher

  • While Kaazing supports a variety of platorms, the following operating systems are recommended for production use:

    • RHEL / CentOS 5 or higher
    • Debian 7 or higher
    • Ubuntu LTS 12.04, LTS 14.04, LTS 16.04
    • Windows Server 2008 R2, 2012

    In addition, other platforms like Windows Desktop and Mac OSX are suitable for development

5.7.1

Release Date: August 1, 2017

What's New

  • Fixed an issue when running in a JVM configured with a HTTP proxy. Gateway now resolves the proxy hostname on each invocation, and sends the fully qualified target hostname instead of the resolved IP address in the HTTP CONNECT (tickets#1132)

Known Issues

  • Due to a known issue with Kaspersky antivirus software, WebSocket connections may fail if Kaspersky is enabled (tickets#602)

    Workaround: Use TLS or disable the antivirus software.

Deprecations

  • None

System Requirements

  • Java Developer Kit (JDK) or Java Runtime Environment (JRE) Java 8 (version 1.8.0_77) or higher

  • While Kaazing supports a variety of platorms, the following operating systems are recommended for production use:

    • RHEL / CentOS 5 or higher
    • Debian 7 or higher
    • Ubuntu LTS 12.04, LTS 14.04, LTS 16.04
    • Windows Server 2008 R2, 2012

    In addition, other platforms like Windows Desktop and Mac OSX are suitable for development

5.7.0

Release Date: July 28, 2017

What's New

  • KWIC comes with a new setup tool (kwic.setup) to quickly configure KWIC for the most common scenarios See documentation

  • In order to help validate that your configuration is working, KWIC includes a netcat-like tool (kwic.test) to verify end-to-end connectivity is working See documentation

  • Added template configurations for KWIC. Look at the reference examples to see how to configure KWIC, or run them using Docker. See the kwic.docker.tutorials repo on GitHub for details.

Known Issues

  • Due to a known issue with Kaspersky antivirus software, WebSocket connections may fail if Kaspersky is enabled (tickets#602)

    Workaround: Use TLS or disable the antivirus software.

Deprecations

  • None

System Requirements

  • Java Developer Kit (JDK) or Java Runtime Environment (JRE) Java 8 (version 1.8.0_77) or higher

  • While Kaazing supports a variety of platorms, the following operating systems are recommended for production use:

    • RHEL / CentOS 5 or higher
    • Debian 7 or higher
    • Ubuntu LTS 12.04, LTS 14.04, LTS 16.04
    • Windows Server 2008 R2, 2012

    In addition, other platforms like Windows Desktop and Mac OSX are suitable for development